[FIXED] App refreshes/reloads config every 30 seconds

Not sure if this is the same issue or not, but I just upgraded to 1.5.2 (build 15115) and am still seeing some wierd behaviour related to this on my android phone (Samsung Galaxy S21).

When first opening the app, it takes approx 30 secs to “fully load”. The way I can tell this is that on my main dashboard it doesn’t show the hub mode or the HSM status (or any other tile status eg. lights) for almost spot on 30 seconds.

And then like clockwork, every 30 seconds afterwards, the screen goes blank like its refreshing/reloading its connection and we go through the cycle again.

i’ve taken a screen recording of the behaviour which is available at the following link Hubivue refrersh bug - YouTube


@dcoghlan can you outline any specific situation with you dashboard - is this a Guest tokencode logging in with / testing that you’re running, or your full account that you’re testing against.

I’m trying to establish the exact sequence that is causing the 30 second refresh - as you can probably guess, this is a situation I’ve not yet seen or encounted.

no worries. I am using my normal full account for testing.

When I open the app, for a brief moment (i.e. less than 1 second) the dashboard looks to load correctly, as in all the tiles are loaded with all their statuses. It looks like its reading from its cache, but then it looks to do a refresh as if its wanting to get the latest updates from the server. Its at this point, the screen flashes black and then loads the dashboard again, but this time there appears to be no status/details for ALL tiles. It stays this way for ~30 seconds and then loads ALL tile statuses. it then appears to stay “good” for about 30 seconds, upon which it looks like it starts the refresh cycle all over again, which starts with the screen flashes black again quickly and then all the tiles loose all of their statuses while it waits 30 seconds again to update correctly.

1 Like

Okay… cool, yep, that’s kinda what I was expecting, but wanted to make sure

I’m looking at some cases where this might be caused by a few things… will hopefully have this sorted shortly.


@dcoghlan can you please tap the Refresh icon to reload the dashboard config from the cloud

I’m also building a new beta right now, but doing this may just fix it, and the bugs I’ve sorted will stop this from happening again (I think)… let me know if the refresh fixes things


1 Like

So i tried using the refresh button (both when the dashboard was fully loaded and when it was “stuck” in the refresh cycle). If the dashboard was fully loaded and working when I hit it, it reloads and has no statuses for around 24-30 seconds.

If I hit it when its already mid refresh, it doesn’t appear to reset the “30 secs” which means if it hit it close to 20 seconds after it started its own refresh, it still loads after a few seconds due to the original refresh which occured.

1 Like

Whilst we’re waiting for the new builds to be published, can you logout of the app and login again? I’m puzzled over how you’re seeing a specifically different startup problem that I haven’t been able to replicate yet - ie I can load/restart/refresh various different accounts/platforms and never once see this problem occur. Puzzling… :frowning:

1 Like

So i did a complete logout & close app and log back in and it looks like it loaded the dashboard correctly from the cache without the initial refresh, but after 30sec to 1 min it started going through the refresh cycle again just as before. I just made another recording of it if you want and I also send in the debug logs.

@dcoghlan build 15119 is available and I’d be keen to know if it has improved things for you.

1 Like

Just installed 15119 and the behaviour initially was still the same. I then logged out and closed the app, re-opened it and logged back in, but the behaviour was still the same. I then decided to start playing with settings and when I disabled the option for “Stay Awake” it appeared like it fixed the issue straight away. I have since re-enabled the “Stay Awake” feature and have not had a single re-occurance of the refreshing issues as initially experienced.

I have the phone with HubiVue sitting next to my work monitor so it was easy to visually see when it was refreshing previously as the screen would go blank and the HSM tiles would go blank, but for the last 10-15 mins its been rock solid, whereas it was refreshing every 30 secs previously.

1 Like

Yay! :heart:

Well to be honest I found lots of silly bugs that had crept in over the months in the way it was caching things and how it resumed / paused the connections. So the exercise has definitely made the app more robust in that space. Hopefully you won’t see any reoccurrence (unless you save a new dash config, then it will reload as expected within a min of the changes)

Fingers crossed I’ve got this licked :stuck_out_tongue: