[FIXED] Dashboard very laggy or unresponsive

I’m seeing this morning that my dashbord is very slow (taking up to 15 seconds to respond), and frequently non responsive. I can activate the same devices on the native dashboards or the hubitat dashboard app and they respond as expected.

In a few instances I have been able to activate a device in the hubitat dashboard app and deactive with hubivue. After doing that a few times it will start to work as expected.
I have picked up two updates between late last night and this morning.

Can you be more specific about what’s slow - are you saying the actions of the tiles or the scrolling or moving / switching betweeN dashboards.

If it’s slow due to actions/updates from tiles to devices, are you 100% sure the device hubiVue is running on a local network (the connection status icon in the menu is a hub vs cloud) ??

Another option is that your Hubitat hub is struggling trying to respond to a large number of MakerAPI requests due to a big number of devices x total number of hubiVue apps running simultaneously. Can you share what the environment is - maybe I need to add a throttling/polling option so you can reduce the update rate for some hubiVue apps running on tablets?

I’ll need more information on this - any details you can share will help

Also what platform as I now have 5 different ways the app could be used on too :flushed:

1 Like

Yes. The action of the tiles. Specifically two RGBW bulbs, just taping the tile to turn on, no responce. Turn on with hubitat dashboard can turn off with hubivue, cannot turn back on with Hubivue. Repeat the process of on with HD, off with Hubivue about 5 times. Finally starts working with no delay for hubivue.
These are the same devices I have been using since I started using Hubivue, and haven’t had this issue until this morning. I actually have a pretty small system currently, Total of 38 devices exposed to Hubivue via Maker api.

Yes, on my local network.

But then woukdnt I be seeing the same priblem wirh Hubitat Dashboard app (also uses MakerAPI)? Thats working just fine.

In both situations (Hubivue and Hubitat Dashboard App) I only have one instance on my phone, and one on my fire tablet (which is powered off).

Im not quite sure what this means, could you elaborate?

Android 12 on Galaxy Note 20 UIltra 5G

So it’s specifically those devices. Do you find the other devices in hubiVue working normally?

Okay, so can you try the individual on and off commands in the info table (has the running man next to them) and let me know if they respond normally/better?

Also, you will see the update rate of the MakerAPI in the last updated at the top of the table too… just make sure that’s every 1-2 seconds or better

Thanks for working with me on this

After that little kickstart routine described earlier, the two devices have been working fine. I did try the individual on off commands and they worked as well.

Now, I did find another that’s not responding. This one is a device group (3-fixture lamp, as one device). The group device doesnt respond to turn on, but will turn off if turned of from HD. The individual bulbs (that make up the group) do work correctly when turned on/ off individually. I tried the individual on/off commands for the group device from(I), and those did work.

I also have a zooz dimmer switch, and that is responding as expected. Door lock, and garage door also working as expected. Everything else are more monitoring devices rather thN actionable devices

The last updated on that group device is running 2 to 4 seconds. Not consistently some time 2, then 1, thrn 4, then 3…

That’s important to me. If you can verify that more consistently then I think I may know what the issue is and how to resolve it… thanks

I will keep an eye on it. It sems there are at least a couple devices or device groups that the update from MakerAPI is bouncing around between 2 and 4 seconds.

The one group device seems to have a pattern 2 sec, 3 sec, 2 sec, 3 sec, 3 sec, 2 sec, repeat. Tapping that tile it does not respond. Going in to (I) and toggling from there it works.

Well, I got it to work by creating a new tile and deleting the old one. Maybe it’s just me, but it seems like there may still be something going on there. You shouldn’t have to randomly recreate and delete tiles to get them to work.

Agree. I have added an option to email your account the dashboard config and a makerAPI dump. The point of that is backup and to help with issues like this - if you had a copy prior and a copy now of the config, I could probably see why the old tile was causing issues if there was a bug. I can’t think what it would be, but maybe the older releases of hubiVue (before I fixed the bugs in tile override) had issues that were causing problems ???


Have made some changes that should fix this and be in the next release