[FIXED] Duplicate Dashboard

Is there a way to duplicate a dashboard with all its tiles? I tried Edit Dashboard > Duplicate, but I get a copy of the dashboard with no tiles.

1 Like

That’s probably a bug. I’ll take a look and confirm shortly.

I’m not seeing any issue - can you replicate the problem?

@LibraSun can you try this and let us know if you have problems?

Poor choice of words.

So to clarrify, are you saying you don’t see any bug/issues and that Duplicate dashboards is working as expected?

1 Like

So I took a look at this again and here’s what I initially got when I did this with the Mac app. Original and duplicated.

Then I noticed on my phone that the tiles had indeed copied over, so I took the Mac out of edit mode, hit the refresh, and the tiles appeared. I guess when in doubt, refresh…

1 Like

Roger. Everything working as expected. Cannot reproduce other user’s issue(s), since every time I attempt to ‘Duplicate’ an existing dashboard in HV, I succeed.

I suspect there is an unusual case around when this might occur.

@dhylander can you replicate this consistently (ie create and delete, create and delete etc) or was it a once off thing that seems to be not occuring now ??

I’ll take a look at the code again and make sure everything is being refreshed inside correctly when I duplicate a dashboard… as it might be a stale cache thing

1 Like

@g.slender I tried several more times after having closed the Mac app and duplicating the phone dashboards now is fine, everything is showing up without refreshing. I did however run into something else when I duplicated my 12 column Max Screen dash (Mac Main), where is copy column setting changed to 3, and on closer examination one of the phone sized dashboards had been duplicated, although the name of the dash was Mac Main Copy. I’m going to boot my Mac and see if this intermittent behavior persists.

FYI Dashboards are defined by an ID# and not the name.

Also, if you are editing between Mac and Phone at the same time, I would guarantee you will have issues. The config sync isn’t smart enough to handle that use case. I should probably introduce an editing lock that refuses to allow edit if you can’t grab the lock. That would avoid any chance of issues

1 Like

Seems wise, if as yet a tad premature. One day, tho’…

After rebooting things seem more in line. I was not editing on the phone at the same time as the Mac, just using it to confirm the display. I have noticed that if you don’t do a save after each duplicate, things start to get out of sync again. Yesterday when I was doing a lot of copy / pasting between dashboards, or replicating the same tile style on a dashboard, after 4 or 5 times, response would slow down where it would take a couple of seconds for a pick drop down to open up. Doing a save gets it back to normal.

Save is the only point when it will copy the current config on that app, back up into the cloud. At the next polling period (currently every min) apps running on other devices will check their cache against the cloud, and if different reload. This keeps devices in sync with the current config. It is rudimentary and works for most cases - the exception would be real-time editing where you are trying to see the outcome on another device immediately. Best option would be to refresh (on the phone) after a save (on the Mac).

This could be a nasty side effect around how I do the undo/redo history - I’m effectively keeping a compressed copy of the last config for every change you make (ie the number of times you press undo etc). This could add up to be too much memory for the app/device to cope with (possiblity but I’ve not tested this limit) and maybe that’s what you’re seeing !?

A save essentially drops the history list, and releases all the memory back again. So not surprised this would free up the performance.

I will look into this, and see if there is any issue.

Going to leave this bug open for now.

Thanks for all your input and feedback.

1 Like