[FIXED] Icons don't rotate / glow

Not aware of this or why it would occur for some devices but not others. Do you think you can share some specifics with a repeatable example - and then maybe share your dash configuration as it might help me track this bug down.

I noticed just now that I had a default icon chosen while I had Overides icons for both open and closed and wondered if that was the problem. After setting the default to none still no luck with glow or rotating icon overrides.

I’ve already forgotten how to email myself the json file. If that file has info that will point you to the issue remind me how to get that file and I’ll forward it to you.

I think I may know the issue… I haven’t tested where the tile has no icon (or the wrong one) and you are relying 100% on the icon overrides to set the default and changed state.

My original thinking (of which the code/logic flows from) is that you set the tile with the default icon (ie closed door) and you have a tile icon override that changes it to open when a state is met.

I don’t know (off the top of my head) what would happen if you didn’t have a default icon set and relied on tile icon overrides for open and closed. I’m guessing a bug exists that stops that situation from working correctly… so will look into it.

But if you can try to remove the extra icon override and put the tile default icon in to see if that sorts it

BTW - the send config email is via…Accounts menu…

Tried this and still no rotate or glow.



For Glow and Rotate to work is there a chance you only have those allowable if the device has what seems like appropriate attribute values coming from Hubitat?

Switch has off and on so glow would work. Fans have Speed so rotate works. I’m asking a contact sensor to glow or rotate and it does not have off or on or speed.

Nah… the overrides (all of them) work simply by looking for pattern matches… ie if you check a fan, it just matches a speed text value to a rotate speed. Something else must be up. Can you email the config to yourself and then fwd to me via email.

1 Like

Found the bug and working on a fix shortly… thanks !


Fixed in the next release due shortly

1 Like

Just installed v1.2.3, glow works, but rotation doesn’t. Looking at the thermostat tile (it is the only one i have like that).

Show me the tile override or send me your dashboard config as I can’t see why it would be failing.

I haven’t changed anything. It’s the stock tile. It worked for me until this update. But hang on a sec.

I have that same tile (more or less) in several configurations and they all work.

I actually fixed a scenario where it wasn’t working.

I haven’t changed anything with it. I just forwarded the configuration files to you.

Okay. Thanks. A bit baffling then :thinking:

Do a full refresh on the dashboard - ie on the view mode it has a circular arrow icon. Refresh.

I think it will then start working

Also, make sure the device you are running on is actually the latest release. If you update a Windows device you must also update all other apps running hubiVue

Nope. I just updated on this device, haven’t updated windows yet.

Just did a refresh several times, still not moving.

I’ll figure it out. Sorry :disappointed:

I looked at and also tried your dashboard configuration against my emulation hub - and everything is working as expected. Icons rotate when the thermostatMode is not off as per your tile override.

One thing you can do to confirm things is this…

Note that I changed the Value that ≠ (Not Equals) is matching for to “blah”, of which you had “off”.

When I do that, as the thermostatMode does not equal blah, it immediately (for me) starts to rotate the icon in the tile edit screen.

This concept of checking the override behaviour in the edit screen can work for any of the conditions as long as you know the attribute, and what you expect it to behave like.

Another example is the condition [] (Contains) which matches / meets the condition when the attribute has any of the letters in value… so this next example works too (if the attribute thermostatMode has any letters with an ‘o’ in it - such as words like “off” or “on” or “open” it will then rotate the icon slowly.

For me, all these tests work using v1.2.3 build 12049

As a final check, can you upgrade to Windows, or use the hubiVue web version to confirm that indeed it isn’t working for you - as that might help we know if we are looking at a device specific issue that isn’t showing up on other platforms.

ie I’ve tried Android, but Google have several millions types of “Android” out there, and I definitely don’t have a way to accurately test your device like I can do with Apple - and that’s one positive thing about developing with Apple (they have a very closed and accurate platform to develop against).