[FIXED] Thermostat controller not responding

Trying to lower my thermostat a degree or two, and it’s not redponding. Taping the minus just one back you completely out of the tile without making any changes

All that does is adjust the cooling/heating setPoint - I’m guessing your AC either just ignores these settings or they are changing and you’re not seeing it anywhere obvious. Maybe check the Hubitat logs?

I’ve still yet to add the controls on the front (or even in the dialog) to adjust “the” actual setThermostatSetpoint… so my bad as its not 100% finished yet :frowning:

I’ll check, but I mean the actual tile isn’t responding, the set point didn’t change on the tile. I would tap minus to lower the cooling set point and it would just go back to the main screen without changing the set point. There is a bug with that tile.

Hard to say. I’d need your config and MakerAPI json files emailed to check

I can get you the config file, what address does that need to be sent to? as for the Maker API json files, I can’t even try to get those until this afternoon, and I’ll need some assistance on that. I have no idea how to access those.

If you have access to hubiVue it will email you all the json files needed - just fwd the email you receive to support@hubivue.com

But also try with v1.1.5 before as I have made some changes to try and fix it

Ahhh… ok … I just sent it. disregard that. I’ll pull an update and try again shortly.

Just updated and tried again, still happening. I sent you the config files and also sent you a screen recording of it happening so you can see what I’m seeing.

Please make sure you’re using v1.1.5 as the bug in the screen recording was specifically fixed in that release, so I doubt that’s the latest being used in that …???

The second configuration file I sent was after updating, as was the screen recording. Just tried it again, the bug is still there.

Just sent a third config file, screen shot of the app version and a new screen recording.

The reason I say, is that the bug was limiting the temp to 50 and you can see that in the original recording. That bug waa fixed in v1.1.5

Try again and untick Apply on change so you can confirm the temp was actually accepted

If it still isn’t working, I will need to add some debug logs and a way to capture them - the thermostat issues are hard because every Hubitat driver does something different

I am on 1.1.5., have bee since this about 10:00CDT (US) this morning.

The last 2 screen recordings I sent were v1.1.5. The config files, and screen recording are from less than 10 minutes ago, running v1.1.5 build 268. Just checked again, if there’s a build after 268 the play store isnt giving it to me.


Is it a driver issue if any attempt to change anything kicks you out of the tile and back to the dashboard? It’s doing that before it even tries to send the command to the hub.

The driver im using is the Ecobee Thermostat system driver.

Enabled debug logging on the hub, this is anot generating any log event on the hub at all, to the command isn’t being sent back to the hub.

I am getting these errors on MakerAPI. But the times do not correspond to when ive tried to test this.

Can you try this?

The “kicking you out” is by design - all the dialogs auto-close / Apply on change so that the number of taps are limited. Idea being you tap tile and slide or tap the change you want to make without having to tap Apply to make the change happen.

@g.slender can you write more about this config and Maker API json file? Where do I find these items?

Account dialog in the main menu.

I think I need to stop coding and write some user guides and publish these.

1 Like

Hey Clay, what I mean is that I will need to enable some logging mode in the hubiVue app, and a mechanism to have them sent to me so that I can review what’s going on. This will be a feature of the next release so I can troubleshoot issues like this, as unfortunately I can’t replicate this - if you create a virtual thermostat, you will probably find it works fine - so whilst you’re saying it isn’t a driver issue, it probably is - most of the problems are often dealing with undocumented quirks in how MakerAPI or drivers work.


@g.slender I’ve got the Ecobee 3 Lite running a brand new dual fuel, 2 stage heat pump so I’ll be watching this thread.
When I just tested the + - thing by bumping the - one time and that sent my cooling set point from 75 to down 65. My unit appears to have gotten the message because it went from stage 1 to stage 2 as a result of the increased cooling demand. I need to hear more about what you are expecting out of the little checkbox labeled Apply On Change…

If you uncheck that, you can change the settings (any/all of them) but the result of the change won’t apply/sent until after the tap Apply. The default behaviour for the tile dialogs is that 1 change is immediately applied - so for changing a fan from high to low, or a level from 90% to 10% is a single tap action. Other more complex actions (like multiple changes to RGB or Thermostat) would require you to untick that Apply On Change first so that you can change more than 1 thing before they are all applied.