Hubitat echo speaks with HV

Has anyone added echo devices to their dashboard that are connected via echo speaks on Hubitat? I’d like to be able to control the volume of the echo in the dashboard. Is this possible?

1 Like

I will be away from keyboard for the next few days, but I’m curious how you currently control the echo volume from your hub. Or have you just been doing it through voice commands on actual echo devices thus far?
Some interesting approaches come to mind so I will keep my thinking cap on.

HubiVue can only (currently) control devices that expose their controls via MakerAPI

If you have more details on the API for control these speakers, I can provide more details.

Looks possible and fairly simple

I’ve only been controlling the echo volume via rule machine on the hub. I actually figured out that using the level option in hubivue works to control the volume. It displays as brightness, but actually does control volume.

1 Like

Yes, that’s what I’m using.

V1.6 of hubiVue is about to be released which adds a tile surface slider, that would be another option. Also Show Position is another option that might work.

1 Like

Thanks Grant, I updated this morning. The surface slider displays the current volume position which is nice, but doesn’t seem to allow for changing the volume (at least on IOS).

Tried the Show Position option as well, but it didn’t work either.

Can you explain that behaviour in more detail? What do you mean is doesn’t allow for changing - are you saying the slider doesn’t move when you drag it, or it does, but the volume doesn’t change? Can you use the slider on a dimmer light and that does work fine, or can you never get the light to work.

Finally, what’s the attribute name? Is it level or volume, in which case what’s the command name use here??

The slider doesn’t move when I attempt to drag it. I tried on a dimmer light as well and get the same result.

The attribute name is volume. I believe the command will work with either setLevel or setVolume. I’ve tried both and neither of them changes slider not moving.

Using the “Show Level Slider” option for single tap still works to change the volume even though it says brightness, so whatever command that uses definitely works.

However just as I was about to hit send I discovered that it will work once you switch from edit dash mode to show dash mode. When in edit dash mode (even if the edit eye button is switched to show instead of edit), the sliders don’t work. Once you switch to show mode they will work and it does correctly set the volume with the setLevel or setVolume command.


That’s the expected behavior. Learned that the hard way myself.


Correct. I’m stuck with needing the touch events from the slider to be ignored otherwise you wouldn’t be able to edit the tiles. In the same way as you can’t tap, hold the tiles when on the dashboard too. But yes I could enable the slider in the edit preview window to be consistent with being able to touch / hold on preview window.

Thoughts about all this?

Do I need to add more obvious grid or EDIT MODE overlay text to warn people?

I think just enabling the slider with the edit preview so it responds correctly just like the tap and hold would clear up any confusion.


I’ll ensure that makes it into a future release v1.6.1

1 Like